خوش آموز اولین و تنها سایت آموزشی %100 رایگان ایران با 6158 آموزش متنی، تصویری و ویدئویی

آموزش تغییر Native Vlan در سوئیچ

آموزش تغییر Native Vlan در سوئیچ

کد مطلب : 5730 PDF

Native Vlan یکی از موضوعات بسیار مهم در فناوری سوئیچینگ است. Native vlan نقش بسیار مهمی را در امنیت و انتقال فریم های بازی می کند. لطفا توپولوژی زیر را در نظر بگیرید که یک روتر به یک سوئیچ Core متصل است. به این سوئیچ Core سوئیچ لایه سه است، سه سوئیچ Access متصل هستند. و vlan های 5,10,15,20 در تمامی این سوئیچ ها ایجاد شده است. این سوئیچ ها با استفاده از یک لینک Trunk به سوئیچ Core متصل شده اند.

دوره آموزش رایگان ریاضی پایه و جبر
تکنولوژی Trunking یک تکنولوژی لایه 2 است. در پورت های Trunk، همه فریم ها با Vlan های مربوطه تگ گذاری می شوند و به پورت ترانک دیگر انتقال پیدا می کنند. برای این منظور در سوئیچینگ شبکه ها، همه سوئیچ ها توسط پورت های Trunk متصل می شوند.

آموزش تغییر Native Vlan در سوئیچ . آموزشگاه رایگان خوش آموز

همانطور که در تصویر فوق مشاهده می کنید یک روتر به سوئیچ Core متصل شده است. سوئیچ Core هیچ فریم بر چسب گذاری شده مربوط به Vlan را از سوی روتری که پورت G0/1 متصل شده، دریافت نمی کند بلکه فریم های بدون تگ یا Untagged را از روتر دریافت می کند. در این سناریو، فریم های Untagged دریافت شده از روتر به Native VLAN ارسال می شود و وظیفه Native VLAN این است که ترافیک مربوطه را بدون تگ از روی لینک Trunk حمل کند. بصورت پیشفرض همانطور که می دانید Vlan1 در واقع همان Native VLAN در سوئیچ های سیسکو است. برای اهداف امنیتی توصیه می شود که vlan Native پیش فرض را به یک vlan دیگر تغییر دهید. پس با هم اینکار را انجام می دهیم.

ابتدای امر پیکربندی ابتدایی را در تمامی سوئیچ ها انجام می دهیم.
دستورات زیر مربوط به پیکربندی سوئیچ Core می باشد:


core-switch(config-vlan)#vlan 10
core-switch(config-vlan)#vlan 15
core-switch(config-vlan)#vlan 20
core-switch(config-vlan)#vlan 100
core-switch(config-vlan)#ex
core-switch(config)#interface range fa0/2-4
core-switch(config-if-range)#switchport trunk encapsulation dot1q
core-switch(config-if-range)#switchport mode trunk
core-switch(config-if-range)#exit

دستورات زیر هم مربوط به پیکربندی سوئیچ های Access می باشد:
سوئیچ اول:

SW-1(config)#vlan 5
SW-1(config-vlan)#vlan 10
SW-1(config-vlan)#vlan 15
SW-1(config-vlan)#vlan 20
SW-1(config-vlan)#vlan 100
SW-1(config-vlan)#interface fa0/1
SW-1(config-if)#switchport mode trunk

سوئیچ دوم:

SW-2(config)#vlan 5
SW-2(config-vlan)#vlan 10
SW-2(config-vlan)#vlan 15
SW-2(config-vlan)#vlan 20
SW-2(config-vlan)#vlan 100
SW-2(config-vlan)#interface fa0/1
SW-2(config-if)#switchport mode trunk

سوئیچ سوم:

SW-3(config)#vlan 5
SW-3(config-vlan)#vlan 10
SW-3(config-vlan)#vlan 15
SW-3(config-vlan)#vlan 20
SW-3(config-vlan)#vlan 100
SW-3(config-vlan)#interface fa0/1
SW-3(config-if)#switchport mode trunk

خب، اکنون می توانید وضعیت native vlan موجود را بررسی کنید:
در سوئیچ Core:

Core-switch# show interface trunk

آموزش تغییر Native Vlan در سوئیچ . آموزشگاه رایگان خوش آموز

در سوئیچ اول:

SW-1#show interface trunk

آموزش تغییر Native Vlan در سوئیچ . آموزشگاه رایگان خوش آموز

اگر همین سناریوی عملی را شما هم پیاده سازی کرده باشید و دستورات را اجرا کنید دقیقا خروجی دستور فوق برای سوئیچ های دوم و سوم هم به منوال بالا خواهد بود.
حالا اجازه دهید که Native vlan را برای VLAN 100 در تمامی سوئیچ ها برای پورت های Trunk پیکربندی کنیم.
دستورات مربوط به تغییر Native VLAN در سوئیچ Core:

core-switch(config)#interface range fa0/2-4
core-switch(config-if-range)#switchport trunk native vlan 100

برای سوئیچ اول:

SW-1(config)#interface fa0/1
SW-1(config-if)#switchport trunk native vlan 100

برای سوئیچ دوم:

SW-2(config)#interface fa0/1
SW-2(config-if)#switchport trunk native vlan 100

برای سوئیچ سوم:

SW-3(config)#interface fa0/1
SW-3(config-if)#switchport trunk native vlan 100

حال وضعیت native vlan را در تمامی سوئیچ ها بررسی کنید:

آموزش تغییر Native Vlan در سوئیچ . آموزشگاه رایگان خوش آموز


آموزش تغییر Native Vlan در سوئیچ . آموزشگاه رایگان خوش آموز

دقت داشته باشید که VLAN 100 ایجاد نشده بلکه اگر VLAN با شماره 100 در این سوئیچ ها ایجاد شود، آن Native Vlan خواهد بود و در نتیجه هر پورتی که عضو این Native Vlan باشد بسته های اطلاعاتی آن Vlan، در سوئیچ برچسب گذاری نمی شود.






دیدگاه ها(0)

دیدگاه خود را ثبت کنید:

لطفا پیش از ارسال دیدگاه ، به نکات زیر توجه فرمایید :

- از نوشتن دیدگاه های غیر مرتبط با پست جدا خودداری کنید.
- لطفاً دیدگاه های خود را با حروف فارسی تایپ کنید، دیدگاه های فینگیلیش تایید نمی شوند.
- قبل از ارسال دیدگاه حتما متن پست و نظرات سایر دوستان را بخوانید . نظرات اسپم و تکراری تایید نخواهند شد.
- نظر شما ممکن است بدون پاسخ تایید شوند که در این صورت باید منتظر پاسخ از سوی دیگر کاربران باشید .
- لطفا انتقادات و پیشنهادات و همچنین درخواست های خود را از طریق ایمیل khoshamoz[at].hotmail.com ارسال نمایید
- چرا آموزش های سایت خوش آموز در قالب فایل pdf به صورت یکجا ارائه نمی شوند؟
- چرا برخی پرسش های کاربران پاسخ داده نمی شوند؟